Mac OS X @ P5K SE/EPU AHCI bios

Обнаружив на одном из наших форумов настойчивое пожелание установить на имеющуюся P5K SE биос от P5KR и увидеть AHCI опцию в BIOS, а заодно перестать мучиться с драйверами для винтов я сильно задумался. Раньше, когда я только разбирался с этим AHCI я пришёл в выводу, что есть ICH9 без AHCI, а есть ICH9R с AHCI. Превратить из одного в другой нельзя в силу железных различий. Но оказалось, что AHCI режим отдаётся на откуп разработчикам BIOS или драйверов операционных систем.

Таким образом, действительно можно получить поддержку AHCI на ICH9 чипсете путём внесения необходимых изменений в биос, а попросту перепрошить близкородственным биосом с поддержкой AHCI. По приходу домой создал загрузочную флешку, скинул 2 биоса, сделал батник на восстановление своего биоса, и прошил P5KR. Не стал я сбрасывать CMOS, ни до, ни после, как советовал автор совета про перепрошивку. Но всё равно AHCI появился и что самое интересное – заработал. Mac OS X загрузилась после выставления режима AHCI в биос, и такое ощущение, что сделала это быстрее. Но, имхо, это не более чем показалось.

Последующие тесты винта каких-либо кардинальных различий в скоростях не показали. Проверил я в Snow Leopard – всё работает. Заодно я сделал изменения в DSDT.aml, что бы система принимала мой AHCI за ICH10R AHCI и добавил в /Extra/Extension injector для избавления от оранжевых иконок дисков. “Рулез”,- сказал я и уже практически решил обосноваться в Snow Leo и решил подбить под это дело более серьёзное обоснование, чем просто всё работает. Если бы не было бы так много написано про ужастные проблемы в Snow Leopard, то никакого бы обоснования мне не потребовалось бы. :)

Как первый пунктик я проверил скорость работы дисков и процессора. Шок это не то слово. С дисками всё было путём. А вот про процессор поподробнее: в тесте mCoreTest64, кроме результатов теста ещё выводится информация о прохождении этого же теста на процессоре E8400@3.0Ghz. У меня именно такой и разогнанный до 4Ghz. Так вот, образцовый процессор должен выдавать где-то чуть больше 5000 попугаев, мой же после разгона выдавал под 7000 попугаев, тут же он выдал не более 4000. Я убрал, на всякий случай, разгон, но результат подтвердился: вместо 5тыс попугаев я имел 3.2тыс на той же самой частоте, и на том же самом процессоре.

Хм, сказал я и вернул BIOS взад. Результат порадовал – снова 5тыс без и под 7тыс попугаев с разгоном. Видимо, что-то не так накладывается и проц начинает работать медленее, а может и не только процессор. Но я-то не лыком шит и уже почувствовал прелесть AHCI, ибо чем меньше модулей – тем лучше и роднее. Я полез на сайт и проштудировал все остальные платы от Asustek на P35 чипсете с ICH9R на борту, теперь-то мы знаем, что это никакая не другая железка, а всё тот же самый ICH9 с поддержкой в биос. Самым близким вариантом оказалась плата P5K PRO. PRO, так PRO и залил биос в свою маму. Скидывать CMOS опять же не стал, поставил AHCI режим и загрузился – результат был на уровне 7тыс.

Сколько я потом не возращался обратно на родной P5K SE/EPU, проверяя предположение, что может быть купленная видеокарта ATI 4850 глючит из-за биоса от P5K PRO, ни разу я не получил другого результата под родным биосом. Так что можно сказать, что биос у меня встал как влитой, разве что я отключаю все устройства на “маме”, кроме звуковой платы.

Да, и надо памятник поставить тому, что написал injectors для ALC883 для Snow Leopard. Работает всё от SPDIF до авторегулировки уровня микрофона, причём и под 10.5.8 тоже! Может быть это следствие не только инжекторов, но ещё и осталось что-то прописанно в DSDT.aml, ведь я долго безуспешно пытался завести звук через DSDT. Не суть, главное что сейчас звук работает с инжекторами!

Как апофеоз всему этому, я сделал 2 флешки: одну с оригинальным дистрибутививом 10.5.6, другую с Snow Leopard, на каждую поставил Chameleon и свой набор Extra, который позволяет загрузиться с уcтановочного диска и поставить Mac OS без каких либо проблем. А если долждаться конца инсталляции, и как только инсталятор начинает обратный отсчёт до перезагрузки вызвать Terminal и в нём поставить Chameleon на вновь установленный экземпляр Mac OS, да скопировать каталог Extra, то после перезагрузке в установленную ОС мы получаем её полностью рабочую и встречающую видеоклипом в полном разрешении экрана и со звуком! :)